class Gem::PlatformMismatch

Generated when trying to lookup a gem to indicate that the gem was found, but that it isn't usable on the current platform.

fetch and install read these and report them to the user to aid in figuring out why a gem couldn't be installed.



the name of the gem


The platforms that are mismatched


the version

Public Class Methods

new(name, version) click to toggle source
# File lib/rubygems/errors.rb, line 74
def initialize(name, version)
  @name = name
  @version = version
  @platforms = []

Public Instance Methods

add_platform(platform) click to toggle source

append a platform to the list of mismatched platforms.

Platforms are added via this instead of injected via the constructor so that we can loop over a list of mismatches and just add them rather than perform some kind of calculation mismatch summary before creation.

# File lib/rubygems/errors.rb, line 86
def add_platform(platform)
  @platforms << platform
wordy() click to toggle source

A wordy description of the error.

# File lib/rubygems/errors.rb, line 92
def wordy
  "Found %s (%s), but was for platform%s %s" %
     @platforms.size == 1 ? '' : 's',
     @platforms.join(' ,')]